Streaming Issue on PBS.org
Incident Report for PBS Public Status
Resolved
We are marking this issue as resolved following yesterday's fix. Any further reports or concerns that this issue is still occurring for a viewer can be submitted at digitalsupport.pbs.org.
Posted Mar 22, 2024 - 13:48 EDT
Monitoring
Earlier today we released a potential fix for the sign-in issue, and we are currently monitoring error reports.
Posted Mar 21, 2024 - 15:06 EDT
Update
We are continuing to investigate this issue, though we are closer to identifying the cause and have been able to reproduce the issue on our side. As a workaround, any users who encounter this issue while streaming on PBS.org can resume watching videos by signing out and signing back in on the PBS.org website.
Posted Mar 20, 2024 - 13:00 EDT
Investigating
We're currently investigating an issue where some PBS Passport users encounter frozen or stalled videos during playback and must log in again to continue watching videos. So far, this issue has only occurred on PBS.org; we have seen no reports of users encountering this issue on the PBS App.

If you encounter any similar user cases, please submit a support ticket at digitalsupport.pbs.org with the user's email address and whether or not they are open to being contacted by PBS Support with follow-up questions.
Posted Mar 19, 2024 - 14:37 EDT
This incident affected: PBS Website and PBS Account.