PBS KIDS Video playback issues on Roku

Incident Report for PBS Public Status

Resolved

We've released a fix to the affected Roku devices and video playback on the PBS KIDS Video channel has been restored for those users.
Posted Jun 17, 2021 - 10:25 EDT

Investigating

We’re investigating playback issues on the PBS KIDS Video app on Roku. Updates will be posted here as we learn more.
Posted Apr 08, 2021 - 13:19 EDT
This incident affected: PBS KIDS (PBS KIDS OTT App).