Apple ID Login Error on PBS.org
Incident Report for PBS Public Status
Resolved
This incident has been resolved, and users signing in with Apple ID can log in without issue.
Posted Feb 08, 2024 - 09:32 EST
Investigating
Users who sign into PBS through Apple ID are currently encountering an error message: "We're sorry, but something went wrong. We've been notified about this issue and we'll take a look at it shortly."

Users who try signing in with Apple ID will encounter this error message after submitting their personal Apple ID credentials. Users will not be able to sign in with Apple ID until this issue is resolved, but other login methods are functioning.

We suspect the error is due to a recent update made by Apple that's affecting our account services partner, but we are still investigating.

This issue is high-priority. Please subscribe to this page for future updates related to this issue.
Posted Feb 06, 2024 - 16:47 EST
This incident affected: PBS Account.